# CVE-2020-7611: Micronaut's HTTP client is vulnerable to HTTP Request Header Injection

> Attackers can inject HTTP request headers in Micronaut HTTP client, potentially bypassing security controls or modifying requests.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-694p-xrhg-x3wm, SNYK-JAVA-IOMICRONAUT-561342

## What is CVE-2020-7611?

CVE-2020-7611 is a critical vulnerability in io.micronaut:micronaut-http-client, published on 30 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of io.micronaut:micronaut-http-client before 1.2.11 and all versions from 1.3.0 before 1.3.2 are vulnerable to HTTP Request Header Injection due to not validating request headers passed to the client.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2020-7611?

4 open source packages ship an affected version, including io.micronaut:micronaut-http-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.micronaut:micronaut-http-client` | Maven | All versions | 1.2.11 |
| `io.micronaut:micronaut-http-client` | Maven | All versions | 1.2.11 |
| `io.micronaut:micronaut-http-client` | Maven | From 1.3.0 | 1.3.2 |
| `io.micronaut:micronaut-http-client` | Maven | From 1.3.0 | 1.3.2 |

Products: Objectcomputing Micronaut.

## How do I fix CVE-2020-7611?

Upgrade io.micronaut:micronaut-http-client to a fixed version for your release line: 1.2.11 or 1.3.2.

## Is CVE-2020-7611 being exploited?

There is no known exploitation of CVE-2020-7611 in the wild and no public exploit code.

## Other vulnerabilities in io.micronaut:micronaut-http-client

- [CVE-2026-33013](https://insights.sbomify.com/CVE-2026-33013/): Micronaut vulnerable to DoS via crafted form-urlencoded body binding with descending array indices (high 8.2)
- [CVE-2026-33012](https://insights.sbomify.com/CVE-2026-33012/): Micronaut Framework vulnerable to a Denial of Service in HTML error response caching (high 7.5)
- [CVE-2021-32769](https://insights.sbomify.com/CVE-2021-32769/): Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in micronaut-core (high 7.5)
- [CVE-2022-21700](https://insights.sbomify.com/CVE-2022-21700/): Memory leak in micronaut-core (medium 5.3)
- [CVE-2024-23639](https://insights.sbomify.com/CVE-2024-23639/): micronaut-core management endpoints vulnerable to drive-by localhost attack (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7611 and fix it if it is affected.

What it is: CVE-2020-7611 is a critical vulnerability in io.micronaut:micronaut-http-client, published on 30 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7611 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.micronaut:micronaut-http-client (Maven): affected all versions; fixed in 1.2.11
- io.micronaut:micronaut-http-client (Maven): affected all versions; fixed in 1.2.11
- io.micronaut:micronaut-http-client (Maven): affected from 1.3.0; fixed in 1.3.2
- io.micronaut:micronaut-http-client (Maven): affected from 1.3.0; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7611/ (Markdown: https://insights.sbomify.com/CVE-2020-7611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7611
- OSV: https://osv.dev/vulnerability/CVE-2020-7611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7611/
Summaries are generated and may contain mistakes; the official description above is the record.
