# CVE-2020-7613: Clamscan vulnerable to command injection

> Attackers can execute arbitrary commands via the _is_clamav_binary function if a specific folder exists, affecting clamscan users.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5v25-xr56-phph, SNYK-JS-CLAMSCAN-564113

## What is CVE-2020-7613?

CVE-2020-7613 is a high-severity command injection vulnerability in clamscan, published on 7 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

clamscan through 1.2.0 is vulnerable to Command Injection. It is possible to inject arbitrary commands as part of the `_is_clamav_binary` function located within `Index.js`. It should be noted that this vulnerability requires a pre-requisite that a folder should be created with the same command that will be chained to execute. This lowers the risk of this issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-7613?

2 open source packages ship an affected version, including clamscan. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clamscan` | npm | All versions | 1.3.0 |
| `clamscan` | npm | All versions | 1.3.0 |

Products: Clamscan Project Clamscan.

## How do I fix CVE-2020-7613?

Upgrade clamscan to 1.3.0 or later.

## Is CVE-2020-7613 being exploited?

There is no known exploitation of CVE-2020-7613 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7613 and fix it if it is affected.

What it is: CVE-2020-7613 is a high-severity command injection vulnerability in clamscan, published on 7 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7613 in the wild and no public exploit code.

Affected packages and fixed versions:
- clamscan (npm): affected all versions; fixed in 1.3.0
- clamscan (npm): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7613/ (Markdown: https://insights.sbomify.com/CVE-2020-7613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7613
- OSV: https://osv.dev/vulnerability/CVE-2020-7613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7613/
Summaries are generated and may contain mistakes; the official description above is the record.
