# CVE-2020-7622: HTTP Response Splitting

> Attackers can perform HTTP response splitting due to missing header validation in the Jooby Netty library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-gv3v-92v6-m48j, SNYK-JAVA-IOJOOBY-564249

## What is CVE-2020-7622?

CVE-2020-7622 is a medium-severity vulnerability in io.jooby:jooby-netty, published on 6 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package io.jooby:jooby-netty before 1.6.9, from 2.0.0 and before 2.2.1. The DefaultHttpHeaders is set to false which means it does not validates that the header isn't being abused for HTTP Response Splitting.

## Which versions are affected by CVE-2020-7622?

2 open source packages ship an affected version, including io.jooby:jooby-netty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jooby:jooby-netty` | Maven | All versions | 2.2.1 |
| `io.jooby:jooby-netty` | Maven | All versions | 2.2.1 |

Products: Jooby Jooby.

## How do I fix CVE-2020-7622?

Upgrade io.jooby:jooby-netty to 2.2.1 or later.

## Is CVE-2020-7622 being exploited?

There is no known exploitation of CVE-2020-7622 in the wild and no public exploit code.

## Other vulnerabilities in io.jooby:jooby-netty

- [CVE-2019-15477](https://insights.sbomify.com/CVE-2019-15477/): Cross-site Scripting in Jooby (medium 6.1)
- [CVE-2020-7647](https://insights.sbomify.com/CVE-2020-7647/): path traversal in Jooby (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7622 and fix it if it is affected.

What it is: CVE-2020-7622 is a medium-severity vulnerability in io.jooby:jooby-netty, published on 6 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7622 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jooby:jooby-netty (Maven): affected all versions; fixed in 2.2.1
- io.jooby:jooby-netty (Maven): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7622/ (Markdown: https://insights.sbomify.com/CVE-2020-7622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7622
- OSV: https://osv.dev/vulnerability/CVE-2020-7622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7622/
Summaries are generated and may contain mistakes; the official description above is the record.
