# CVE-2020-7642: Cross-site scripting in lazysizes

> Attackers can inject malicious JavaScript via unsanitized video embed attributes in the lazysizes library, leading to code execution in the victim's browser.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hg2p-2cvq-4ppv, SNYK-JS-LAZYSIZES-567144

## What is CVE-2020-7642?

CVE-2020-7642 is a medium-severity cross-site scripting vulnerability in lazysizes, published on 22 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

lazysizes through 5.2.0 allows execution of malicious JavaScript. The following attributes are not sanitized by the video-embed plugin: data-vimeo, data-vimeoparams, data-youtube and data-ytparams which can be abused to inject malicious JavaScript.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-7642?

2 open source packages ship an affected version, including lazysizes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lazysizes` | npm | All versions | 5.2.1 |
| `lazysizes` | npm | All versions | 5.2.1 |

Products: Lazysizes Project Lazysizes.

## How do I fix CVE-2020-7642?

Upgrade lazysizes to 5.2.1 or later.

## Is CVE-2020-7642 being exploited?

There is no known exploitation of CVE-2020-7642 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7642 and fix it if it is affected.

What it is: CVE-2020-7642 is a medium-severity cross-site scripting vulnerability in lazysizes, published on 22 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-7642 in the wild and no public exploit code.

Affected packages and fixed versions:
- lazysizes (npm): affected all versions; fixed in 5.2.1
- lazysizes (npm): affected all versions; fixed in 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7642/ (Markdown: https://insights.sbomify.com/CVE-2020-7642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7642
- OSV: https://osv.dev/vulnerability/CVE-2020-7642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7642/
Summaries are generated and may contain mistakes; the official description above is the record.
