# CVE-2020-7647: path traversal in Jooby

> Attackers can exploit directory traversal vectors in the Jooby web framework to read arbitrary files from the server.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-px9h-x66r-8mpc

## What is CVE-2020-7647?

CVE-2020-7647 is a medium-severity path traversal vulnerability in io.jooby:jooby and org.jooby:jooby, published on 11 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions before 1.6.7 and all versions after 2.0.0 inclusive and before 2.8.2 of io.jooby:jooby and org.jooby:jooby are vulnerable to Directory Traversal via two separate vectors.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-7647?

4 open source packages ship an affected version, including io.jooby:jooby and org.jooby:jooby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jooby:jooby` | Maven | All versions | 2.8.2 |
| `io.jooby:jooby` | Maven | All versions | 2.8.2 |
| `org.jooby:jooby` | Maven | All versions | 2.8.2 |
| `org.jooby:jooby` | Maven | All versions | 2.8.2 |

Products: Jooby Jooby.

## How do I fix CVE-2020-7647?

Upgrade io.jooby:jooby to 2.8.2 or later.

## Is CVE-2020-7647 being exploited?

There is no known exploitation of CVE-2020-7647 in the wild and no public exploit code.

## Other vulnerabilities in io.jooby:jooby and org.jooby:jooby

- [CVE-2020-7622](https://insights.sbomify.com/CVE-2020-7622/): HTTP Response Splitting (medium 6.5)
- [CVE-2019-15477](https://insights.sbomify.com/CVE-2019-15477/): Cross-site Scripting in Jooby (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7647 and fix it if it is affected.

What it is: CVE-2020-7647 is a medium-severity path traversal vulnerability in io.jooby:jooby and org.jooby:jooby, published on 11 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7647 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jooby:jooby (Maven): affected all versions; fixed in 2.8.2
- io.jooby:jooby (Maven): affected all versions; fixed in 2.8.2
- org.jooby:jooby (Maven): affected all versions; fixed in 2.8.2
- org.jooby:jooby (Maven): affected all versions; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7647/ (Markdown: https://insights.sbomify.com/CVE-2020-7647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7647
- OSV: https://osv.dev/vulnerability/CVE-2020-7647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7647/
Summaries are generated and may contain mistakes; the official description above is the record.
