# CVE-2020-7649: Directory Traversal

> An attacker with internal network access can read arbitrary files via directory traversal in the Snyk broker package.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-gq75-5gc3-rfwg

## What is CVE-2020-7649?

CVE-2020-7649 is a medium-severity path traversal vulnerability in snyk-broker, published on 25 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

This affects the package snyk-broker before 4.73.0. It allows arbitrary file reads for users with access to Snyk's internal network via directory traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-7649?

2 open source packages ship an affected version, including snyk-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snyk-broker` | npm | All versions | 4.73.0 |
| `snyk-broker` | npm | All versions | 4.73.0 |

Products: Snyk Broker.

## How do I fix CVE-2020-7649?

Upgrade snyk-broker to 4.73.0 or later.

## Is CVE-2020-7649 being exploited?

There is no known exploitation of CVE-2020-7649 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7649 and fix it if it is affected.

What it is: CVE-2020-7649 is a medium-severity path traversal vulnerability in snyk-broker, published on 25 Jul 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7649 in the wild and no public exploit code.

Affected packages and fixed versions:
- snyk-broker (npm): affected all versions; fixed in 4.73.0
- snyk-broker (npm): affected all versions; fixed in 4.73.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7649/ (Markdown: https://insights.sbomify.com/CVE-2020-7649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7649
- OSV: https://osv.dev/vulnerability/CVE-2020-7649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7649/
Summaries are generated and may contain mistakes; the official description above is the record.
