{"answers":{"affected":"3 open source packages ship an affected version, including meinheld. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7658 in the wild and no public exploit code.","fix":"Upgrade meinheld to 1.0.2 or later.","what":"CVE-2020-7658 is a medium-severity vulnerability in meinheld, published on 22 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-7658 and fix it if it is affected.\n\nWhat it is: CVE-2020-7658 is a medium-severity vulnerability in meinheld, published on 22 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-7658 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- meinheld (PyPI): affected all versions; fixed in 1.0.2\n- meinheld (PyPI): affected all versions; fixed in 1.0.2\n- meinheld (PyPI): affected all versions; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7658/ (Markdown: https://insights.sbomify.com/CVE-2020-7658/index.md)","id":"CVE-2020-7658","markdown":"https://insights.sbomify.com/CVE-2020-7658/index.md","name":"CVE-2020-7658","record":{"aliases":["GHSA-63h2-9cc8-fc7m","PYSEC-2020-239","SNYK-PYTHON-MEINHELD-569140"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python WSGI server","requires_auth":"none","summary":"Attackers can exploit HTTP request smuggling via incorrect header parsing in the meinheld server, potentially bypassing security controls or accessing sensitive data.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"meinheld","vendor":"meinheld"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"meinheld vulnerable to HTTP Request Smuggling","id":"CVE-2020-7658","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"HTTP Request Smuggling in reel","id":"CVE-2020-7659"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"meinheld","purl":null,"source":"GHSA-63h2-9cc8-fc7m"},{"ecosystem":"PyPI","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"meinheld","purl":"pkg:pypi/meinheld","source":"GHSA-63h2-9cc8-fc7m"},{"ecosystem":"PyPI","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"meinheld","purl":"pkg:pypi/meinheld","source":"PYSEC-2020-239"}],"prev":{"headline":"Cross-Site Scripting in jquery","id":"CVE-2020-7656"},"products":["meinheld"],"published":"2020-05-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can exploit HTTP request smuggling via incorrect header parsing in the meinheld server, potentially bypassing security controls or accessing sensitive data.","url":"https://insights.sbomify.com/CVE-2020-7658/"}