# CVE-2020-7658: meinheld vulnerable to HTTP Request Smuggling

> Attackers can exploit HTTP request smuggling via incorrect header parsing in the meinheld server, potentially bypassing security controls or accessing sensitive data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-63h2-9cc8-fc7m, PYSEC-2020-239, SNYK-PYTHON-MEINHELD-569140

## What is CVE-2020-7658?

CVE-2020-7658 is a medium-severity vulnerability in meinheld, published on 22 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2020-7658?

3 open source packages ship an affected version, including meinheld. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `meinheld` | PyPI | All versions | 1.0.2 |
| `meinheld` | PyPI | All versions | 1.0.2 |
| `meinheld` | PyPI | All versions | 1.0.2 |

Products: Meinheld Meinheld.

## How do I fix CVE-2020-7658?

Upgrade meinheld to 1.0.2 or later.

## Is CVE-2020-7658 being exploited?

There is no known exploitation of CVE-2020-7658 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7658 and fix it if it is affected.

What it is: CVE-2020-7658 is a medium-severity vulnerability in meinheld, published on 22 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-7658 in the wild and no public exploit code.

Affected packages and fixed versions:
- meinheld (PyPI): affected all versions; fixed in 1.0.2
- meinheld (PyPI): affected all versions; fixed in 1.0.2
- meinheld (PyPI): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7658/ (Markdown: https://insights.sbomify.com/CVE-2020-7658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7658
- OSV: https://osv.dev/vulnerability/CVE-2020-7658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7658/
Summaries are generated and may contain mistakes; the official description above is the record.
