# CVE-2020-7660: Insecure serialization leading to RCE in serialize-javascript

> Remote attackers can inject arbitrary code via the deleteFunctions method in the serialize-javascript library, requiring an upgrade to mitigate.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hxcc-f52p-wc94, ROOT-APP-NPM-CVE-2020-7660

## What is CVE-2020-7660?

CVE-2020-7660 is a high-severity code injection vulnerability in serialize-javascript, published on 1 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

serialize-javascript prior to 3.1.0 allows remote attackers to inject arbitrary code via the function "deleteFunctions" within "index.js".

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-7660?

2 open source packages ship an affected version, including serialize-javascript. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serialize-javascript` | npm | All versions | 3.1.0 |
| `serialize-javascript` | npm | All versions | 3.1.0 |

Products: Verizon Serialize-Javascript.

## How do I fix CVE-2020-7660?

Upgrade serialize-javascript to 3.1.0 or later.

## Is CVE-2020-7660 being exploited?

There is no known exploitation of CVE-2020-7660 in the wild and no public exploit code.

## Other vulnerabilities in serialize-javascript

- [CVE-2019-16769](https://insights.sbomify.com/CVE-2019-16769/): Affected versions of serialize-javascript are vulnerable to Cross-site Scripting (XSS) (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7660 and fix it if it is affected.

What it is: CVE-2020-7660 is a high-severity code injection vulnerability in serialize-javascript, published on 1 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7660 in the wild and no public exploit code.

Affected packages and fixed versions:
- serialize-javascript (npm): affected all versions; fixed in 3.1.0
- serialize-javascript (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7660/ (Markdown: https://insights.sbomify.com/CVE-2020-7660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7660
- OSV: https://osv.dev/vulnerability/CVE-2020-7660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7660/
Summaries are generated and may contain mistakes; the official description above is the record.
