# CVE-2020-7662: Regular Expression Denial of Service in websocket-extensions (NPM package)

> An attacker can cause a Denial of Service in applications using the websocket-extensions library by sending a malicious Sec-WebSocket-Extensions header that triggers quadratic regex backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-44202, CLSA-2026-1773188138, GHSA-g78m-2chm-r7qv, SNYK-JS-WEBSOCKETEXTENSIONS-570623

## What is CVE-2020-7662?

CVE-2020-7662 is a high-severity denial of service vulnerability in websocket-extensions (npm), published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

websocket-extensions npm module prior to 0.1.4 allows Denial of Service (DoS) via Regex Backtracking. The extension parser may take quadratic time when parsing a header containing an unclosed string parameter value whose content is a repeating two-byte sequence of a backslash and some other character. This could be abused by an attacker to conduct Regex Denial Of Service (ReDoS) on a single-threaded server by providing a malicious payload with the Sec-WebSocket-Extensions header.

## Which versions are affected by CVE-2020-7662?

2 open source packages ship an affected version, including websocket-extensions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `websocket-extensions` | npm | All versions | 0.1.4 |
| `websocket-extensions` | npm | All versions | 0.1.4 |

Products: Websocket-Extensions Project Websocket-Extensions.

## How do I fix CVE-2020-7662?

Upgrade websocket-extensions to 0.1.4 or later.

## Is CVE-2020-7662 being exploited?

There is no known exploitation of CVE-2020-7662 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7662 and fix it if it is affected.

What it is: CVE-2020-7662 is a high-severity denial of service vulnerability in websocket-extensions (npm), published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7662 in the wild and no public exploit code.

Affected packages and fixed versions:
- websocket-extensions (npm): affected all versions; fixed in 0.1.4
- websocket-extensions (npm): affected all versions; fixed in 0.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7662/ (Markdown: https://insights.sbomify.com/CVE-2020-7662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7662
- OSV: https://osv.dev/vulnerability/CVE-2020-7662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7662/
Summaries are generated and may contain mistakes; the official description above is the record.
