# CVE-2020-7663: Regular Expression Denial of Service in websocket-extensions (RubyGem)

> An attacker can cause a Denial of Service in Ruby applications using the websocket-extensions library by sending a malicious Sec-WebSocket-Extensions header.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-7663, DLA-2334-1, GHSA-g6wq-qcwm-j5g2, OESA-2022-1553, OESA-2022-2093, SNYK-RUBY-WEBSOCKETEXTENSIONS-570830, SUSE-SU-2023:0127-1, UBUNTU-CVE-2020-7663, USN-4502-1, openSUSE-SU-2024:11357-1, openSUSE-SU-2024:13173-1, openSUSE-SU-2024:14180-1, openSUSE-SU-2025:15130-1, openSUSE-SU-2026:10368-1

## What is CVE-2020-7663?

CVE-2020-7663 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

websocket-extensions ruby module prior to 0.1.5 allows Denial of Service (DoS) via Regex Backtracking. The extension parser may take quadratic time when parsing a header containing an unclosed string parameter value whose content is a repeating two-byte sequence of a backslash and some other character. This could be abused by an attacker to conduct Regex Denial Of Service (ReDoS) on a single-threaded server by providing a malicious payload with the Sec-WebSocket-Extensions header.

## Which versions are affected by CVE-2020-7663?

2 open source packages ship an affected version, including websocket-extensions. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `websocket-extensions` | RubyGems | All versions | 0.1.5 |
| `websocket-extensions` | RubyGems | All versions | 0.1.5 |
| `rubygem-websocket-extensions` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 0.1.3-150000.3.4.1 |
| `rubygem-websocket-extensions` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 0.1.3-150000.3.4.1 |
| `rubygem-websocket-extensions` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 0.1.3-150000.3.4.1 |
| `rubygem-websocket-extensions` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 0.1.3-150000.3.4.1 |
| `rubygem-websocket-extensions` | openSUSE:Leap 15.4 | All versions | 0.1.3-150000.3.4.1 |
| `ruby3.2-rubygem-websocket-extensions` | openSUSE:Tumbleweed | All versions | 0.1.5-1.16 |
| `rubygem-websocket-extensions` | openSUSE:Tumbleweed | All versions | 0.1.5-1.20 |
| `rubygem-websocket-extensions` | openSUSE:Tumbleweed | All versions | 0.1.5-1.22 |
| `rubygem-websocket-extensions` | openSUSE:Tumbleweed | All versions | 0.1.5-1.24 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Websocket-Extensions Project Websocket-Extensions.

## How do I fix CVE-2020-7663?

Upgrade websocket-extensions to 0.1.5 or later.

## Is CVE-2020-7663 being exploited?

There is no known exploitation of CVE-2020-7663 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7663 and fix it if it is affected.

What it is: CVE-2020-7663 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 2 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7663 in the wild and no public exploit code.

Affected packages and fixed versions:
- websocket-extensions (RubyGems): affected all versions; fixed in 0.1.5
- websocket-extensions (RubyGems): affected all versions; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7663/ (Markdown: https://insights.sbomify.com/CVE-2020-7663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7663
- OSV: https://osv.dev/vulnerability/CVE-2020-7663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7663/
Summaries are generated and may contain mistakes; the official description above is the record.
