# CVE-2020-7677: Arbitrary Code Execution


- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L/E:P/RL:U/RC:C`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2020-7677, DLA-3128-1, GHSA-29xr-v42j-r956, UBUNTU-CVE-2020-7677, USN-6016-1

## What is CVE-2020-7677?

CVE-2020-7677 is a high-severity vulnerability in Debian Debian Linux, published on 25 Jul 2022. 

### Official description

This affects the package thenify before 3.3.1. The name argument provided to the package can be controlled by users without any sanitization, and this is provided to the eval function without any sanitization.

## Which versions are affected by CVE-2020-7677?

4 open source packages ship an affected version, including org.webjars.npm:thenify and thenify. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.webjars.npm:thenify` | Maven | All versions | 3.3.1 |
| `org.webjars.npm:thenify` | Maven | All versions | 3.3.1 |
| `thenify` | npm | All versions | 3.3.1 |
| `thenify` | npm | All versions | 3.3.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Thenify Project Thenify.

## How do I fix CVE-2020-7677?

Upgrade org.webjars.npm:thenify to 3.3.1 or later.

## Is CVE-2020-7677 being exploited?

There is no known exploitation of CVE-2020-7677 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7677 and fix it if it is affected.

What it is: CVE-2020-7677 is a high-severity vulnerability in Debian Debian Linux, published on 25 Jul 2022. 
Exploitation: There is no known exploitation of CVE-2020-7677 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.webjars.npm:thenify (Maven): affected all versions; fixed in 3.3.1
- org.webjars.npm:thenify (Maven): affected all versions; fixed in 3.3.1
- thenify (npm): affected all versions; fixed in 3.3.1
- thenify (npm): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7677/ (Markdown: https://insights.sbomify.com/CVE-2020-7677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7677
- OSV: https://osv.dev/vulnerability/CVE-2020-7677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7677/
Summaries are generated and may contain mistakes; the official description above is the record.
