# CVE-2020-7688: Command Injection

> Attackers can execute arbitrary commands via unsanitized tagName input in the mversion npm library, potentially compromising the host system.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6m8p-4fxj-pgc2, SNYK-JS-MVERSION-573174

## What is CVE-2020-7688?

CVE-2020-7688 is a high-severity command injection vulnerability in mversion, published on 1 Jul 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The issue occurs because tagName user input is formatted inside the exec function is executed without any checks.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-7688?

2 open source packages ship an affected version, including mversion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mversion` | npm | All versions | 2.0.1 |
| `mversion` | npm | All versions | 2.0.1 |

Products: Mversion Project Mversion.

## How do I fix CVE-2020-7688?

Upgrade mversion to 2.0.1 or later.

## Is CVE-2020-7688 being exploited?

There is no known exploitation of CVE-2020-7688 in the wild and no public exploit code.

## Other vulnerabilities in mversion

- [CVE-2020-4059](https://insights.sbomify.com/CVE-2020-4059/): Command Injection in mversion (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7688 and fix it if it is affected.

What it is: CVE-2020-7688 is a high-severity command injection vulnerability in mversion, published on 1 Jul 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7688 in the wild and no public exploit code.

Affected packages and fixed versions:
- mversion (npm): affected all versions; fixed in 2.0.1
- mversion (npm): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7688/ (Markdown: https://insights.sbomify.com/CVE-2020-7688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7688
- OSV: https://osv.dev/vulnerability/CVE-2020-7688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7688/
Summaries are generated and may contain mistakes; the official description above is the record.
