{"answers":{"affected":"2 open source packages ship an affected version, including sockjs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7693 in the wild and no public exploit code.","fix":"Upgrade sockjs to 0.3.20 or later.","what":"CVE-2020-7693 is a medium-severity denial of service vulnerability in sockjs, published on 9 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7693 and fix it if it is affected.\n\nWhat it is: CVE-2020-7693 is a medium-severity denial of service vulnerability in sockjs, published on 9 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7693 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sockjs (npm): affected all versions; fixed in 0.3.20\n- sockjs (npm): affected all versions; fixed in 0.3.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7693/ (Markdown: https://insights.sbomify.com/CVE-2020-7693/index.md)","id":"CVE-2020-7693","markdown":"https://insights.sbomify.com/CVE-2020-7693/index.md","name":"CVE-2020-7693","record":{"aliases":["CLSA-2026-1776731780","CLSA-2026-1784856033","GHSA-c9g6-9335-x697"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js WebSocket library","requires_auth":"none","summary":"Attackers can crash containers hosting SockJS applications by sending a malformed Upgrade header, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"sockjs","vendor":"sockjs_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2020-07-03","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2020-07-03T11:04:48Z","kind":"github_poc","ref":"https://github.com/andsnw/sockjs-dos-py","stars":1,"title":"CVE-2020-7693: SockJS 0.3.19 Denial of Service POC"},{"date":"2026-01-13T13:48:53Z","kind":"github_poc","ref":"https://github.com/thewindghost/CVE-2020-7693","stars":0,"title":"POC For CVE-2020-7693 (Testing on Version sockjs@0.3.18)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2020-7693","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":6,"next":{"headline":"Log Injection","id":"CVE-2020-7694"},"packages":[{"ecosystem":"npm","fixed":["0.3.20"],"introduced":["0"],"last_affected":[],"package":"sockjs","purl":null,"source":"GHSA-c9g6-9335-x697"},{"ecosystem":"npm","fixed":["0.3.20"],"introduced":["0"],"last_affected":[],"package":"sockjs","purl":"pkg:npm/sockjs","source":"GHSA-c9g6-9335-x697"}],"prev":{"headline":"Improper Authorization","id":"CVE-2020-7692"},"products":["sockjs"],"published":"2020-07-09","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in SocksJS-node","id":"CVE-2020-8823","kev_date_added":null,"published":"2020-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can crash containers hosting SockJS applications by sending a malformed Upgrade header, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2020-7693/"}