# CVE-2020-7693: Denial of Service (DoS)

> Attackers can crash containers hosting SockJS applications by sending a malformed Upgrade header, requiring an upgrade to the library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2020
- **Updated:** 17 Sep 2024
- **Also known as:** CLSA-2026-1776731780, CLSA-2026-1784856033, GHSA-c9g6-9335-x697

## What is CVE-2020-7693?

CVE-2020-7693 is a medium-severity denial of service vulnerability in sockjs, published on 9 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2020-7693?

2 open source packages ship an affected version, including sockjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sockjs` | npm | All versions | 0.3.20 |
| `sockjs` | npm | All versions | 0.3.20 |

Products: Sockjs Project Sockjs.

## How do I fix CVE-2020-7693?

Upgrade sockjs to 0.3.20 or later.

## Is CVE-2020-7693 being exploited?

There is no known exploitation of CVE-2020-7693 in the wild and no public exploit code.

Public exploit code:

- CVE-2020-7693: SockJS 0.3.19 Denial of Service POC (github_poc): https://github.com/andsnw/sockjs-dos-py
- POC For CVE-2020-7693 (Testing on Version sockjs@0.3.18) (github_poc): https://github.com/thewindghost/CVE-2020-7693

## Other vulnerabilities in sockjs

- [CVE-2020-8823](https://insights.sbomify.com/CVE-2020-8823/): Cross-site scripting in SocksJS-node (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7693 and fix it if it is affected.

What it is: CVE-2020-7693 is a medium-severity denial of service vulnerability in sockjs, published on 9 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7693 in the wild and no public exploit code.

Affected packages and fixed versions:
- sockjs (npm): affected all versions; fixed in 0.3.20
- sockjs (npm): affected all versions; fixed in 0.3.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7693/ (Markdown: https://insights.sbomify.com/CVE-2020-7693/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7693
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7693
- OSV: https://osv.dev/vulnerability/CVE-2020-7693

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7693/
Summaries are generated and may contain mistakes; the official description above is the record.
