# CVE-2020-7695: HTTP Response Splitting

> Attackers can inject arbitrary headers or response bodies via CRLF injection in Uvicorn, potentially leading to cache poisoning or XSS.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N/E:P/RL:U/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2020
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2020-7695, GHSA-f97h-2pfx-f59f, PYSEC-2020-151, SNYK-PYTHON-UVICORN-570471, UBUNTU-CVE-2020-7695

## What is CVE-2020-7695?

CVE-2020-7695 is a medium-severity vulnerability in uvicorn, published on 27 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uvicorn before 0.11.7 is vulnerable to HTTP response splitting. CRLF sequences are not escaped in the value of HTTP headers. Attackers can exploit this to add arbitrary headers to HTTP responses, or even return an arbitrary response body, whenever crafted input is used to construct HTTP headers.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-7695?

3 open source packages ship an affected version, including uvicorn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uvicorn` | PyPI | All versions | 0.11.7 |
| `uvicorn` | PyPI | All versions | 0.11.7 |
| `uvicorn` | PyPI | All versions | 0.11.7 |

Products: Encode Uvicorn.

## How do I fix CVE-2020-7695?

Upgrade uvicorn to 0.11.7 or later.

## Is CVE-2020-7695 being exploited?

There is no known exploitation of CVE-2020-7695 in the wild and no public exploit code.

## Other vulnerabilities in uvicorn

- [CVE-2020-7694](https://insights.sbomify.com/CVE-2020-7694/): Log Injection (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7695 and fix it if it is affected.

What it is: CVE-2020-7695 is a medium-severity vulnerability in uvicorn, published on 27 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7695 in the wild and no public exploit code.

Affected packages and fixed versions:
- uvicorn (PyPI): affected all versions; fixed in 0.11.7
- uvicorn (PyPI): affected all versions; fixed in 0.11.7
- uvicorn (PyPI): affected all versions; fixed in 0.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7695/ (Markdown: https://insights.sbomify.com/CVE-2020-7695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7695
- OSV: https://osv.dev/vulnerability/CVE-2020-7695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7695/
Summaries are generated and may contain mistakes; the official description above is the record.
