# CVE-2020-7706: Prototype Pollution

> Prototype pollution in connie-lang allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:U/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-8vv3-jxm8-f4vf, SNYK-JS-CONNIELANG-598853

## What is CVE-2020-7706?

CVE-2020-7706 is a critical vulnerability in connie-lang, published on 18 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package connie-lang before 0.1.1 are vulnerable to Prototype Pollution in the configuration language library used by connie.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2020-7706?

2 open source packages ship an affected version, including connie-lang. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `connie-lang` | npm | All versions | 0.1.1 |
| `connie-lang` | npm | All versions | 0.1.1 |

Products: Connie-Lang Project Connie-Lang.

## How do I fix CVE-2020-7706?

Upgrade connie-lang to 0.1.1 or later.

## Is CVE-2020-7706 being exploited?

There is no known exploitation of CVE-2020-7706 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7706 and fix it if it is affected.

What it is: CVE-2020-7706 is a critical vulnerability in connie-lang, published on 18 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7706 in the wild and no public exploit code.

Affected packages and fixed versions:
- connie-lang (npm): affected all versions; fixed in 0.1.1
- connie-lang (npm): affected all versions; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7706/ (Markdown: https://insights.sbomify.com/CVE-2020-7706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7706
- OSV: https://osv.dev/vulnerability/CVE-2020-7706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7706/
Summaries are generated and may contain mistakes; the official description above is the record.
