# CVE-2020-7715: Prototype Pollution

> Prototype pollution in deep-get-set allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-85cp-p426-42f5

## What is CVE-2020-7715?

CVE-2020-7715 is a critical vulnerability in deep-get-set, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of package deep-get-set are vulnerable to Prototype Pollution via the main function.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2020-7715?

2 open source packages ship an affected version, including deep-get-set. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deep-get-set` | npm | All versions | 1.1.1 |
| `deep-get-set` | npm | All versions | 1.1.1 |

Products: Deep-Get-Set Project Deep-Get-Set.

## How do I fix CVE-2020-7715?

Upgrade deep-get-set to 1.1.1 or later.

## Is CVE-2020-7715 being exploited?

There is no known exploitation of CVE-2020-7715 in the wild and no public exploit code.

## Other vulnerabilities in deep-get-set

- [CVE-2022-21231](https://insights.sbomify.com/CVE-2022-21231/): Prototype Pollution (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7715 and fix it if it is affected.

What it is: CVE-2020-7715 is a critical vulnerability in deep-get-set, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7715 in the wild and no public exploit code.

Affected packages and fixed versions:
- deep-get-set (npm): affected all versions; fixed in 1.1.1
- deep-get-set (npm): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7715/ (Markdown: https://insights.sbomify.com/CVE-2020-7715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7715
- OSV: https://osv.dev/vulnerability/CVE-2020-7715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7715/
Summaries are generated and may contain mistakes; the official description above is the record.
