# CVE-2020-7729: Arbitrary Code Execution


- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H/RL:O`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Sep 2020
- **Updated:** 17 Sep 2024
- **Also known as:** AZL-44379, DEBIAN-CVE-2020-7729, DLA-2368-1, GHSA-m5pj-vjjf-4m3h, OESA-2022-1544, OESA-2022-2048, UBUNTU-CVE-2020-7729, USN-4595-1

## What is CVE-2020-7729?

CVE-2020-7729 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 3 Sep 2020. 

### Official description

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2020-7729?

2 open source packages ship an affected version, including grunt. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grunt` | npm | All versions | 1.3.0 |
| `grunt` | npm | All versions | 1.3.0 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Gruntjs Grunt.

## How do I fix CVE-2020-7729?

Upgrade grunt to 1.3.0 or later.

## Is CVE-2020-7729 being exploited?

There is no known exploitation of CVE-2020-7729 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7729 and fix it if it is affected.

What it is: CVE-2020-7729 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 3 Sep 2020. 
Exploitation: There is no known exploitation of CVE-2020-7729 in the wild and no public exploit code.

Affected packages and fixed versions:
- grunt (npm): affected all versions; fixed in 1.3.0
- grunt (npm): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7729/ (Markdown: https://insights.sbomify.com/CVE-2020-7729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7729
- OSV: https://osv.dev/vulnerability/CVE-2020-7729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7729/
Summaries are generated and may contain mistakes; the official description above is the record.
