# CVE-2020-7733: Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service in applications using ua-parser-js by sending specially crafted user agent strings.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-662x-fhqg-9p8v, UBUNTU-CVE-2020-7733

## What is CVE-2020-7733?

CVE-2020-7733 is a high-severity denial of service vulnerability in ua-parser-js, published on 16 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package ua-parser-js before 0.7.22 are vulnerable to Regular Expression Denial of Service (ReDoS) via the regex for Redmi Phones and Mi Pad Tablets UA.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-7733?

2 open source packages ship an affected version, including ua-parser-js. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ua-parser-js` | npm | All versions | 0.7.22 |
| `ua-parser-js` | npm | All versions | 0.7.22 |

Products: Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Ua-Parser-Js Project Ua-Parser-Js.

## How do I fix CVE-2020-7733?

Upgrade ua-parser-js to 0.7.22 or later.

## Is CVE-2020-7733 being exploited?

There is no known exploitation of CVE-2020-7733 in the wild and no public exploit code.

## Other vulnerabilities in ua-parser-js

- [CVE-2020-14343](https://insights.sbomify.com/CVE-2020-14343/): Improper Input Validation in PyYAML (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7733 and fix it if it is affected.

What it is: CVE-2020-7733 is a high-severity denial of service vulnerability in ua-parser-js, published on 16 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7733 in the wild and no public exploit code.

Affected packages and fixed versions:
- ua-parser-js (npm): affected all versions; fixed in 0.7.22
- ua-parser-js (npm): affected all versions; fixed in 0.7.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7733/ (Markdown: https://insights.sbomify.com/CVE-2020-7733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7733
- OSV: https://osv.dev/vulnerability/CVE-2020-7733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7733/
Summaries are generated and may contain mistakes; the official description above is the record.
