# CVE-2020-7735: Command Injection

> Attackers can execute arbitrary commands via the styleIncludePaths option in ng-packagr, requiring an upgrade to secure the build process.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qm28-7hqv-wg5j, SNYK-JS-NGPACKAGR-1012427

## What is CVE-2020-7735?

CVE-2020-7735 is a medium-severity command injection vulnerability in ng-packagr, published on 25 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The package ng-packagr before 10.1.1 are vulnerable to Command Injection via the styleIncludePaths option.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-7735?

2 open source packages ship an affected version, including ng-packagr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ng-packagr` | npm | All versions | 10.1.1 |
| `ng-packagr` | npm | All versions | 10.1.1 |

Products: Ng-Packagr Project Ng-Packagr.

## How do I fix CVE-2020-7735?

Upgrade ng-packagr to 10.1.1 or later.

## Is CVE-2020-7735 being exploited?

There is no known exploitation of CVE-2020-7735 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7735 and fix it if it is affected.

What it is: CVE-2020-7735 is a medium-severity command injection vulnerability in ng-packagr, published on 25 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7735 in the wild and no public exploit code.

Affected packages and fixed versions:
- ng-packagr (npm): affected all versions; fixed in 10.1.1
- ng-packagr (npm): affected all versions; fixed in 10.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7735/ (Markdown: https://insights.sbomify.com/CVE-2020-7735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7735
- OSV: https://osv.dev/vulnerability/CVE-2020-7735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7735/
Summaries are generated and may contain mistakes; the official description above is the record.
