# CVE-2020-7749: Server-side Request Forgery (SSRF)

> Attackers can inject code via unescaped user input, leading to XSS, SSRF, or local file reads in osm-static-maps.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L/E:U/RL:O/RC:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-pxcf-v868-m492

## What is CVE-2020-7749?

CVE-2020-7749 is a high-severity server-side request forgery vulnerability in osm-static-maps, published on 20 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This affects all versions of package osm-static-maps. User input given to the package is passed directly to a template without escaping ({{{ ... }}}). As such, it is possible for an attacker to inject arbitrary HTML/JS code and depending on the context. It will be outputted as an HTML on the page which gives opportunity for XSS or rendered on the server (puppeteer) which also gives opportunity for SSRF and Local File Read.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-7749?

2 open source packages ship an affected version, including osm-static-maps. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `osm-static-maps` | npm | All versions | 3.9.0 |
| `osm-static-maps` | npm | All versions | 3.9.0 |

Products: Osm-Static-Maps Project Osm-Static-Maps.

## How do I fix CVE-2020-7749?

Upgrade osm-static-maps to 3.9.0 or later.

## Is CVE-2020-7749 being exploited?

There is no known exploitation of CVE-2020-7749 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7749 and fix it if it is affected.

What it is: CVE-2020-7749 is a high-severity server-side request forgery vulnerability in osm-static-maps, published on 20 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7749 in the wild and no public exploit code.

Affected packages and fixed versions:
- osm-static-maps (npm): affected all versions; fixed in 3.9.0
- osm-static-maps (npm): affected all versions; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7749/ (Markdown: https://insights.sbomify.com/CVE-2020-7749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7749
- OSV: https://osv.dev/vulnerability/CVE-2020-7749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7749/
Summaries are generated and may contain mistakes; the official description above is the record.
