{"answers":{"affected":"4 open source packages ship an affected version, including npm-user-validate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7754 in the wild and no public exploit code.","fix":"Upgrade npm-user-validate to 1.0.1 or later.","what":"CVE-2020-7754 is a high-severity denial of service vulnerability in npm-user-validate, published on 27 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7754 and fix it if it is affected.\n\nWhat it is: CVE-2020-7754 is a high-severity denial of service vulnerability in npm-user-validate, published on 27 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7754 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- npm-user-validate (npm): affected all versions; fixed in 1.0.1\n- npm-user-validate (npm): affected all versions; fixed in 1.0.1\n- npm-user-validate (npm): affected all versions; fixed in 1.0.1\n- npm-user-validate (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7754/ (Markdown: https://insights.sbomify.com/CVE-2020-7754/index.md)","id":"CVE-2020-7754","markdown":"https://insights.sbomify.com/CVE-2020-7754/index.md","name":"CVE-2020-7754","record":{"aliases":["CLSA-2026-1772583197","CLSA-2026-1784682764","GHSA-pw54-mh39-w3hc","GHSA-xgh6-85xh-479p","ROOT-APP-NPM-CVE-2020-7754"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm validation library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing long email inputs starting with @, triggering exponential regex processing in the npm-user-validate library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"npm-user-validate","vendor":"npmjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"This affects the package npm-user-validate before 1.0.1. The regex that validates user emails took exponentially longer to process long input strings beginning with @ characters.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2020-7754","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":4,"n_references":4,"next":{"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2020-7755"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"npm-user-validate","purl":null,"source":"GHSA-pw54-mh39-w3hc"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"npm-user-validate","purl":"pkg:npm/npm-user-validate","source":"GHSA-pw54-mh39-w3hc"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"npm-user-validate","purl":null,"source":"GHSA-xgh6-85xh-479p"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"npm-user-validate","purl":"pkg:npm/npm-user-validate","source":"GHSA-xgh6-85xh-479p"}],"prev":{"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2020-7753"},"products":["npm-user-validate"],"published":"2020-10-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by providing long email inputs starting with @, triggering exponential regex processing in the npm-user-validate library.","url":"https://insights.sbomify.com/CVE-2020-7754/"}