# CVE-2020-7761: Regular Expression Denial of Service (ReDoS)

> Attackers can cause a denial of service by submitting crafted invalid emails to applications using this JavaScript validation library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-hgpf-97c5-74fc, SNYK-JS-ABSOLUNETKAFE-1017403

## What is CVE-2020-7761?

CVE-2020-7761 is a medium-severity denial of service vulnerability in @absolunet/kafe, published on 5 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package @absolunet/kafe before 3.2.10. It allows cause a denial of service when validating crafted invalid emails.

## Which versions are affected by CVE-2020-7761?

2 open source packages ship an affected version, including @absolunet/kafe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@absolunet/kafe` | npm | All versions | 3.2.10 |
| `@absolunet/kafe` | npm | All versions | 3.2.10 |

Products: Absolunet Kafe.

## How do I fix CVE-2020-7761?

Upgrade @absolunet/kafe to 3.2.10 or later.

## Is CVE-2020-7761 being exploited?

There is no known exploitation of CVE-2020-7761 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7761 and fix it if it is affected.

What it is: CVE-2020-7761 is a medium-severity denial of service vulnerability in @absolunet/kafe, published on 5 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7761 in the wild and no public exploit code.

Affected packages and fixed versions:
- @absolunet/kafe (npm): affected all versions; fixed in 3.2.10
- @absolunet/kafe (npm): affected all versions; fixed in 3.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7761/ (Markdown: https://insights.sbomify.com/CVE-2020-7761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7761
- OSV: https://osv.dev/vulnerability/CVE-2020-7761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7761/
Summaries are generated and may contain mistakes; the official description above is the record.
