{"answers":{"affected":"2 open source packages ship an affected version, including @firebase/util. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7765 in the wild and no public exploit code.","fix":"Upgrade @firebase/util to 0.3.4 or later.","what":"CVE-2020-7765 is a medium-severity vulnerability in @firebase/util, published on 16 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7765 and fix it if it is affected.\n\nWhat it is: CVE-2020-7765 is a medium-severity vulnerability in @firebase/util, published on 16 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7765 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @firebase/util (npm): affected all versions; fixed in 0.3.4\n- @firebase/util (npm): affected all versions; fixed in 0.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7765/ (Markdown: https://insights.sbomify.com/CVE-2020-7765/index.md)","id":"CVE-2020-7765","markdown":"https://insights.sbomify.com/CVE-2020-7765/index.md","name":"CVE-2020-7765","record":{"aliases":["GHSA-fpm5-vv97-jfwg","SNYK-JS-FIREBASEUTIL-1038324"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Firebase utility library","requires_auth":"none","summary":"An attacker can pollute the object prototype via the deepExtend function, potentially leading to code execution or security bypasses in applications using this library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"firebase\\/util","vendor":"google"}],"cvss":{"score":5.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C","version":"3.1"},"cwes":[],"description":"This affects the package @firebase/util before 0.3.4. This vulnerability relates to the deepExtend function within the DeepCopy.ts file. Depending on if user input is provided, an attacker can overwrite and pollute the object prototype of a program.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prototype Pollution","id":"CVE-2020-7765","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Prototype Pollution","id":"CVE-2020-7766"},"packages":[{"ecosystem":"npm","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"@firebase/util","purl":null,"source":"GHSA-fpm5-vv97-jfwg"},{"ecosystem":"npm","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"@firebase/util","purl":"pkg:npm/%40firebase/util","source":"GHSA-fpm5-vv97-jfwg"}],"prev":{"headline":"Web Cache Poisoning","id":"CVE-2020-7764"},"products":["@firebase/util"],"published":"2020-11-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can pollute the object prototype via the deepExtend function, potentially leading to code execution or security bypasses in applications using this library.","url":"https://insights.sbomify.com/CVE-2020-7765/"}