# CVE-2020-7769: Command Injection

> Attackers can inject arbitrary command flags via crafted email addresses in the sendmail transport, potentially leading to code execution.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H/E:P/RL:U/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2020
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1784596339, DEBIAN-CVE-2020-7769, GHSA-48ww-j4fc-435p, UBUNTU-CVE-2020-7769

## What is CVE-2020-7769?

CVE-2020-7769 is a high-severity command injection vulnerability in nodemailer, published on 12 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package nodemailer before 6.4.16. Use of crafted recipient email addresses may result in arbitrary command flag injection in sendmail transport for sending mails.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2020-7769?

2 open source packages ship an affected version, including nodemailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 6.4.16 |
| `nodemailer` | npm | All versions | 6.4.16 |

Products: Nodemailer Nodemailer.

## How do I fix CVE-2020-7769?

Upgrade nodemailer to 6.4.16 or later.

## Is CVE-2020-7769 being exploited?

There is no known exploitation of CVE-2020-7769 in the wild and no public exploit code.

## Other vulnerabilities in nodemailer

- [CVE-2025-14874](https://insights.sbomify.com/CVE-2025-14874/): Nodemailer: nodemailer: denial of service via crafted email address header (high 7.5)
- [CVE-2021-23400](https://insights.sbomify.com/CVE-2021-23400/): HTTP Header Injection (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7769 and fix it if it is affected.

What it is: CVE-2020-7769 is a high-severity command injection vulnerability in nodemailer, published on 12 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7769 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 6.4.16
- nodemailer (npm): affected all versions; fixed in 6.4.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7769/ (Markdown: https://insights.sbomify.com/CVE-2020-7769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7769
- OSV: https://osv.dev/vulnerability/CVE-2020-7769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7769/
Summaries are generated and may contain mistakes; the official description above is the record.
