# CVE-2020-7776: Cross-site Scripting (XSS)

> An attacker can execute arbitrary scripts via XSS when a spreadsheet with malicious cell comments is converted to HTML.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4mqv-gcr3-pff9, SNYK-PHP-PHPOFFICEPHPSPREADSHEET-1048856

## What is CVE-2020-7776?

CVE-2020-7776 is a high-severity cross-site scripting vulnerability in phpoffice/phpspreadsheet, published on 9 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This affects the package phpoffice/phpspreadsheet from 0.0.0. The library is vulnerable to XSS when creating an html output from an excel file by adding a comment on any cell. The root cause of this issue is within the HTML writer where user comments are concatenated as part of link and this is returned as HTML. A fix for this issue is available on commit 0ed5b800be2136bcb8fa9c1bdf59abc957a98845/master branch.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-7776?

4 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.16.0 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.16.0 |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2020-7776?

Upgrade phpoffice/phpspreadsheet to 1.16.0 or later.

## Is CVE-2020-7776 being exploited?

There is no known exploitation of CVE-2020-7776 in the wild and no public exploit code.

## Other vulnerabilities in phpoffice/phpspreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7776 and fix it if it is affected.

What it is: CVE-2020-7776 is a high-severity cross-site scripting vulnerability in phpoffice/phpspreadsheet, published on 9 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7776 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.16.0
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.16.0
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7776/ (Markdown: https://insights.sbomify.com/CVE-2020-7776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7776
- OSV: https://osv.dev/vulnerability/CVE-2020-7776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7776/
Summaries are generated and may contain mistakes; the official description above is the record.
