{"answers":{"affected":"2 open source packages ship an affected version, including ini. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-7788 in the wild and no public exploit code.","fix":"Upgrade ini to 1.3.6 or later.","what":"CVE-2020-7788 is a high-severity vulnerability in Debian Debian Linux, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7788 and fix it if it is affected.\n\nWhat it is: CVE-2020-7788 is a high-severity vulnerability in Debian Debian Linux, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7788 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ini (npm): affected all versions; fixed in 1.3.6\n- ini (npm): affected all versions; fixed in 1.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7788/ (Markdown: https://insights.sbomify.com/CVE-2020-7788/index.md)","id":"CVE-2020-7788","markdown":"https://insights.sbomify.com/CVE-2020-7788/index.md","name":"CVE-2020-7788","record":{"aliases":["AZL-44679","AZL-45153","CLSA-2026-1771546204","CLSA-2026-1775608289","DEBIAN-CVE-2020-7788","DLA-2503-1","GHSA-qqgx-2p2h-9c37","MGASA-2021-0068","MINI-363w-q583-jg23","ROOT-APP-NPM-CVE-2020-7788","SNYK-JS-INI-1048974","UBUNTU-CVE-2020-7788"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ini parser","requires_auth":"none","summary":"Attackers can pollute the prototype via malicious INI files, potentially leading to code execution or privilege escalation in applications using the library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"ini","vendor":"ini_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"This affects the package ini before 1.3.6. If an attacker submits a malicious INI file to an application that parses it with ini.parse, they will pollute the prototype on the application. This can be exploited further depending on the context.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prototype Pollution","id":"CVE-2020-7788","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"other","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Command Injection","id":"CVE-2020-7789"},"packages":[{"ecosystem":"npm","fixed":["1.3.6"],"introduced":["0"],"last_affected":[],"package":"ini","purl":null,"source":"GHSA-qqgx-2p2h-9c37"},{"ecosystem":"npm","fixed":["1.3.6"],"introduced":["0"],"last_affected":[],"package":"ini","purl":"pkg:npm/ini","source":"GHSA-qqgx-2p2h-9c37"}],"prev":{"headline":"Improper Authentication","id":"CVE-2020-7787"},"products":["ini"],"published":"2020-12-11","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["n/a"]},"summary":"Attackers can pollute the prototype via malicious INI files, potentially leading to code execution or privilege escalation in applications using the library.","url":"https://insights.sbomify.com/CVE-2020-7788/"}