# CVE-2020-7788: Prototype Pollution

> Attackers can pollute the prototype via malicious INI files, potentially leading to code execution or privilege escalation in applications using the library.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2020
- **Updated:** 8 Oct 2026
- **Also known as:** AZL-44679, AZL-45153, CLSA-2026-1771546204, CLSA-2026-1775608289, DEBIAN-CVE-2020-7788, DLA-2503-1, GHSA-qqgx-2p2h-9c37, MGASA-2021-0068, MINI-363w-q583-jg23, ROOT-APP-NPM-CVE-2020-7788, SNYK-JS-INI-1048974, UBUNTU-CVE-2020-7788

## What is CVE-2020-7788?

CVE-2020-7788 is a high-severity vulnerability in Debian Debian Linux, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package ini before 1.3.6. If an attacker submits a malicious INI file to an application that parses it with ini.parse, they will pollute the prototype on the application. This can be exploited further depending on the context.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2020-7788?

2 open source packages ship an affected version, including ini. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ini` | npm | All versions | 1.3.6 |
| `ini` | npm | All versions | 1.3.6 |

Products: Debian Debian Linux, Ini Project Ini.

## How do I fix CVE-2020-7788?

Upgrade ini to 1.3.6 or later.

## Is CVE-2020-7788 being exploited?

There is no known exploitation of CVE-2020-7788 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7788 and fix it if it is affected.

What it is: CVE-2020-7788 is a high-severity vulnerability in Debian Debian Linux, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7788 in the wild and no public exploit code.

Affected packages and fixed versions:
- ini (npm): affected all versions; fixed in 1.3.6
- ini (npm): affected all versions; fixed in 1.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7788/ (Markdown: https://insights.sbomify.com/CVE-2020-7788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7788
- OSV: https://osv.dev/vulnerability/CVE-2020-7788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7788/
Summaries are generated and may contain mistakes; the official description above is the record.
