# CVE-2020-7789: Command Injection

> Attackers can execute arbitrary commands on Linux systems via unsanitized parameters in the node-notifier library.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2020
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1774916714, CLSA-2026-1787592062, GHSA-5fw9-fq32-wv5p

## What is CVE-2020-7789?

CVE-2020-7789 is a medium-severity command injection vulnerability in node-notifier, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package node-notifier before 9.0.0. It allows an attacker to run arbitrary commands on Linux machines due to the options params not being sanitised when being passed an array.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-7789?

2 open source packages ship an affected version, including node-notifier. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-notifier` | npm | All versions | 8.0.1 |
| `node-notifier` | npm | All versions | 8.0.1 |

Products: Node-Notifier Project Node-Notifier.

## How do I fix CVE-2020-7789?

Upgrade node-notifier to 8.0.1 or later.

## Is CVE-2020-7789 being exploited?

There is no known exploitation of CVE-2020-7789 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7789 and fix it if it is affected.

What it is: CVE-2020-7789 is a medium-severity command injection vulnerability in node-notifier, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7789 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-notifier (npm): affected all versions; fixed in 8.0.1
- node-notifier (npm): affected all versions; fixed in 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7789/ (Markdown: https://insights.sbomify.com/CVE-2020-7789/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7789
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7789
- OSV: https://osv.dev/vulnerability/CVE-2020-7789

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7789/
Summaries are generated and may contain mistakes; the official description above is the record.
