# CVE-2020-7906: Security feature bypass in n/a

> Unsigned binaries in the Windows installer allow bypassing code signing verification, potentially enabling supply chain attacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h8r4-m8jx-qp8j

## What is CVE-2020-7906?

CVE-2020-7906 is a high-severity vulnerability in n/a, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In JetBrains Rider versions 2019.3 EAP2 through 2019.3 EAP7, there were unsigned binaries provided by the Windows installer. This issue was fixed in release version 2019.3.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2020-7906?

It affects 1 product.


Products: Jetbrains Rider.

## How do I fix CVE-2020-7906?

No fix has been published for CVE-2020-7906 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-7906 being exploited?

There is no known exploitation of CVE-2020-7906 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-14960](https://insights.sbomify.com/CVE-2019-14960/): Supply chain in n/a (high 7.8)
- [CVE-2025-43016](https://insights.sbomify.com/CVE-2025-43016/): Path traversal in Rider (medium 5.4)
- [CVE-2026-100265](https://insights.sbomify.com/CVE-2026-100265/): Supply chain in Rider (medium 4.8)
- [CVE-2022-37396](https://insights.sbomify.com/CVE-2022-37396/): Security feature bypass in Rider (medium 4.1)
- [CVE-2024-24939](https://insights.sbomify.com/CVE-2024-24939/): Information disclosure in Rider (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7906 and fix it if it is affected.

What it is: CVE-2020-7906 is a high-severity vulnerability in n/a, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7906 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7906/ (Markdown: https://insights.sbomify.com/CVE-2020-7906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7906
- OSV: https://osv.dev/vulnerability/CVE-2020-7906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7906/
Summaries are generated and may contain mistakes; the official description above is the record.
