# CVE-2020-7919: Helm uses crypto package vulnerable to panic from malformed X.509 certificate

> A malformed X.509 certificate can cause a panic in Go clients, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-golang-2020-7919, CLEANSTART-2025-WZ56191, GHSA-cjjc-xp8v-855w, GO-2022-0229, MGASA-2020-0173, UBUNTU-CVE-2020-7919

## What is CVE-2020-7919?

CVE-2020-7919 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients (resulting in a panic) via a malformed X.509 certificate.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-7919?

9 open source packages ship an affected version, including golang.org/x/crypto, golang and github.com/helm/helm. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang.org/x/crypto` | Go | All versions | 0.0.0-20200124225646-8b5121be2f68 |
| `golang.org/x/crypto` | Go | All versions | 0.0.0-20200124225646-8b5121be2f68 |
| `golang.org/x/crypto` | Go | All versions | 0.0.0-20200124225646-8b5121be2f68 |
| `golang` | Bitnami | From 1.12.0 | 1.12.6, 1.13.7 |
| `github.com/helm/helm` | Go | From 2.0.0 | 2.16.8 |
| `github.com/helm/helm` | Go | From 2.0.0 | 2.16.8 |
| `helm.sh/helm/v3` | Go | From 3.0.0 | 3.1.0 |
| `helm.sh/helm/v3` | Go | From 3.0.0 | 3.1.0 |
| `stdlib` | Go | All versions | 1.12.16, 1.13.7 |

Products: Debian Debian Linux, Fedoraproject Fedora, Golang Go, Netapp Cloud Insights Telegraf.

## How do I fix CVE-2020-7919?

Upgrade golang.org/x/crypto to 0.0.0-20200124225646-8b5121be2f68 or later.

## Is CVE-2020-7919 being exploited?

There is no known exploitation of CVE-2020-7919 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7919 and fix it if it is affected.

What it is: CVE-2020-7919 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7919 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang.org/x/crypto (Go): affected all versions; fixed in 0.0.0-20200124225646-8b5121be2f68
- golang.org/x/crypto (Go): affected all versions; fixed in 0.0.0-20200124225646-8b5121be2f68
- golang.org/x/crypto (Go): affected all versions; fixed in 0.0.0-20200124225646-8b5121be2f68
- golang (Bitnami): affected from 1.12.0; fixed in 1.12.6, 1.13.7
- github.com/helm/helm (Go): affected from 2.0.0; fixed in 2.16.8
- github.com/helm/helm (Go): affected from 2.0.0; fixed in 2.16.8
- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.1.0
- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.1.0
- stdlib (Go): affected all versions; fixed in 1.12.16, 1.13.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7919/ (Markdown: https://insights.sbomify.com/CVE-2020-7919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7919
- OSV: https://osv.dev/vulnerability/CVE-2020-7919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7919/
Summaries are generated and may contain mistakes; the official description above is the record.
