CVE-2020-7924 Specific command line parameter might result in accepting invalid certificate
Attackers can bypass TLS certificate validation in MongoDB tools by using a specific command line parameter, enabling man-in-the-middle attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-7924?
CVE-2020-7924 is a medium-severity vulnerability in MongoDB Database Tools, published on 12 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Usage of specific command line parameter in MongoDB Tools which was originally intended to just skip hostname checks, may result in MongoDB skipping all certificate validation. This may result in accepting invalid certificates.This issue affects: MongoDB Inc. MongoDB Database Tools 3.6 versions later than 3.6.5; 3.6 versions prior to 3.6.21; 4.0 versions prior to 4.0.21; 4.2 versions prior to 4.2.11; 100 versions prior to 100.2.0. MongoDB Inc. Mongomirror 0 versions later than 0.6.0.
Weakness: CWE-295
Which versions are affected by CVE-2020-7924?
3 open source packages ship an affected version, including github.com/mongodb/mongo-tools. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mongodb/mongo-tools Go | All versions | 0.0.0-20200819165540-8c1800b51550 |
github.com/mongodb/mongo-tools Go | From 100.0.0 | 100.2.0 |
github.com/mongodb/mongo-tools Go | From 100.0.0 | 100.2.0 |
Products include Mongodb Database Tools, Mongodb Mongomirror.
How do I fix CVE-2020-7924?
Upgrade github.com/mongodb/mongo-tools to a fixed version for your release line: 0.0.0-20200819165540-8c1800b51550 or 100.2.0.
Is CVE-2020-7924 being exploited?
There is no known exploitation of CVE-2020-7924 in the wild and no public exploit code.
Sources
Also known as GHSA-6cwm-wm82-hgrw, GO-2024-2550.