CVE-2020-7926 Specific query can cause a DoS against MongoDB Server

Medium 6.5 Published Updated

An authorized user can cause a denial of service in MongoDB Server by issuing a specially crafted query that violates server selection invariants.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-7926?

CVE-2020-7926 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 23 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A user authorized to perform database queries may cause denial of service by issuing a specially crafted query which violates an invariant in the server selection subsystem. This issue affects MongoDB Server v4.4 versions prior to 4.4.1. Versions before 4.4 are not affected.

Weakness: CWE-755

Which versions are affected by CVE-2020-7926?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 4.4.04.4.1

Products include Mongodb Mongodb.

How do I fix CVE-2020-7926?

Upgrade mongodb to 4.4.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-7926 being exploited?

There is no known exploitation of CVE-2020-7926 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2020-7926, GHSA-rqw4-wgg4-99m9.

Is CVE-2020-7926 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free