CVE-2020-7928 Improper neutralization of null byte leads to read overrun

Medium 6.5 Published Updated

Authorized users can trigger a read overrun via crafted queries to access arbitrary memory in MongoDB Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-7928?

CVE-2020-7928 is a medium-severity memory corruption vulnerability in Mongodb Mongodb, published on 23 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A user authorized to perform database queries may trigger a read overrun and access arbitrary memory by issuing specially crafted queries. This issue affects MongoDB Server v4.4 versions prior to 4.4.1; MongoDB Server v4.2 versions prior to 4.2.9; MongoDB Server v4.0 versions prior to 4.0.20 and MongoDB Server v3.6 versions prior to 3.6.20.

Weakness: CWE-158

Which versions are affected by CVE-2020-7928?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 3.6.03.6.20, 4.0.20, 4.2.9, 4.4.1, 4.5.1

Products include Mongodb Mongodb.

How do I fix CVE-2020-7928?

Upgrade mongodb to a fixed version for your release line: 3.6.20, 4.0.20, 4.2.9 or 4.4.1.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-7928 being exploited?

There is no known exploitation of CVE-2020-7928 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2020-7928, GHSA-5mwc-rp6j-mw6r, UBUNTU-CVE-2020-7928.

Is CVE-2020-7928 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free