CVE-2020-7929 Specially crafted regex query can cause DoS
An authenticated user can cause a denial of service in MongoDB Server by submitting specially crafted regex queries.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7929?
CVE-2020-7929 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 1 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A user authorized to perform database queries may trigger denial of service by issuing specially crafted query contain a type of regex. This issue affects MongoDB Server v3.6 versions prior to 3.6.21 and MongoDB Server v4.0 versions prior to 4.0.20.
Weakness: CWE-185
Which versions are affected by CVE-2020-7929?
1 open source package ship an affected version, including mongodb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 3.6.0 | 3.6.21, 4.0.20 |
Products include Mongodb Mongodb.
How do I fix CVE-2020-7929?
Upgrade mongodb to a fixed version for your release line: 3.6.21 or 4.0.20.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-7929 being exploited?
There is no known exploitation of CVE-2020-7929 in the wild and no public exploit code.
Other vulnerabilities in Mongodb Mongodb
- CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency
- CVE-2026-82067 Auth bypass in MongoDB Server
- CVE-2026-13072 MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption
- CVE-2017-15535 Denial of service in n/a
- CVE-2026-18691 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure
Sources
Also known as BIT-mongodb-2020-7929, GHSA-4jpm-qv63-23qh, UBUNTU-CVE-2020-7929.