# CVE-2020-7938: Plone Privilege Escallation

> Users with specific privileges can escalate to the highest level in Plone REST API, requiring an upgrade to mitigate.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cjg3-q24h-9qwf, PYSEC-2020-87, PYSEC-2026-2889

## What is CVE-2020-7938?

CVE-2020-7938 is a high-severity vulnerability in Plone Plone, published on 23 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.

## Which versions are affected by CVE-2020-7938?

6 open source packages ship an affected version, including plone, Plone and plone-restapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 5.2.0 | 5.2.2 |
| `plone` | PyPI | From 5.2.0 | 5.2.2 |
| `Plone` | PyPI | From 5.2.0 | 5.2.2 |
| `plone-restapi` | PyPI | All versions | 6.2.1 |
| `plone-restapi` | PyPI | All versions | 6.2.1 |
| `plone.restapi` | PyPI | All versions | 6.2.1 |

Products: Plone Plone.

## How do I fix CVE-2020-7938?

Upgrade plone to 5.2.2 or later.

## Is CVE-2020-7938 being exploited?

There is no known exploitation of CVE-2020-7938 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7938 and fix it if it is affected.

What it is: CVE-2020-7938 is a high-severity vulnerability in Plone Plone, published on 23 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7938 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected from 5.2.0; fixed in 5.2.2
- plone (PyPI): affected from 5.2.0; fixed in 5.2.2
- Plone (PyPI): affected from 5.2.0; fixed in 5.2.2
- plone-restapi (PyPI): affected all versions; fixed in 6.2.1
- plone-restapi (PyPI): affected all versions; fixed in 6.2.1
- plone.restapi (PyPI): affected all versions; fixed in 6.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7938/ (Markdown: https://insights.sbomify.com/CVE-2020-7938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7938
- OSV: https://osv.dev/vulnerability/CVE-2020-7938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7938/
Summaries are generated and may contain mistakes; the official description above is the record.
