CVE-2020-7940 Plone allows weak passwords
Plone allows users to set weak passwords due to missing strength checks, facilitating easier account compromise via brute-force attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-7940?
CVE-2020-7940 is a high-severity vulnerability in Plone Plone, published on 23 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Missing password strength checks on some forms in Plone 4.3 through 5.2.0 allow users to set weak passwords, leading to easier cracking.
Weakness: CWE-521
Which versions are affected by CVE-2020-7940?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 4.3 | 4.3.20 |
plone PyPI | From 4.3 | 5.2.1 |
plone PyPI | From 5.0rc1 | 5.1.7 |
plone PyPI | From 5.2.0 | 5.2.2 |
Plone PyPI | From 4.3 | 4.3.20 |
Plone PyPI | From 5.0rc1 | 5.1.7 |
1 more packages
Plone PyPI | From 5.2.0 | 5.2.2 |
Products include Plone Plone.
How do I fix CVE-2020-7940?
Upgrade plone to a fixed version for your release line: 4.3.20, 5.2.1, 5.1.7 or 5.2.2.
Is CVE-2020-7940 being exploited?
There is no known exploitation of CVE-2020-7940 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-cw58-gpgw-hwx2, PYSEC-2020-89.