{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-7942 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 5.5.19 or 6.13.0.","what":"CVE-2020-7942 is a medium-severity missing authorization vulnerability in Puppet, published on 19 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7942 and fix it if it is affected.\n\nWhat it is: CVE-2020-7942 is a medium-severity missing authorization vulnerability in Puppet, published on 19 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7942 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected all versions; fixed in 5.5.19\n- puppet (RubyGems): affected all versions; fixed in 5.5.19\n- puppet (RubyGems): affected from 6.0.0; fixed in 6.13.0\n- puppet (RubyGems): affected from 6.0.0; fixed in 6.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7942/ (Markdown: https://insights.sbomify.com/CVE-2020-7942/index.md)","id":"CVE-2020-7942","markdown":"https://insights.sbomify.com/CVE-2020-7942/index.md","name":"CVE-2020-7942","record":{"aliases":["DEBIAN-CVE-2020-7942","GHSA-gqvf-892r-vjm5","SUSE-SU-2020:1057-1"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Puppet configuration management","requires_auth":"low_privilege","summary":"Attackers with valid certificates can access other nodes' catalogs by modifying facts, exposing sensitive infrastructure data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"puppet","cpe":[{"product":"puppet","vendor":"puppet"},{"product":"puppet_agent","vendor":"puppet"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Previously, Puppet operated on a model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure. When a node's catalog falls back to the `default` node, the catalog can be retrieved for a different node by modifying facts for the Puppet run. This issue can be mitigated by setting `strict_hostname_checking = true` in `puppet.conf` on your Puppet master. Puppet 6.13.0 and 5.5.19 changes the default behavior for strict_hostname_checking from false to true. It is recommended that Puppet Open Source and Puppet Enterprise users that are not upgrading still set strict_hostname_checking to true to ensure secure behavior. Affected software versions: Puppet 6.x prior to 6.13.0 Puppet Agent 6.x prior to 6.13.0 Puppet 5.5.x prior to 5.5.19 Puppet Agent 5.5.x prior to 5.5.19 Resolved in: Puppet 6.13.0 Puppet Agent 6.13.0 Puppet 5.5.19 Puppet Agent 5.5.19","ecosystems":["RubyGems","SUSE:Linux Enterprise Module for Advanced Systems Management 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in Puppet","id":"CVE-2020-7942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2020"},"n_packages":5,"n_references":1,"next":{"headline":"Information disclosure in Puppet Enterprise","id":"CVE-2020-7943"},"packages":[{"ecosystem":"RubyGems","fixed":["5.5.19"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-gqvf-892r-vjm5"},{"ecosystem":"RubyGems","fixed":["5.5.19"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-gqvf-892r-vjm5"},{"ecosystem":"RubyGems","fixed":["6.13.0"],"introduced":["6.0.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-gqvf-892r-vjm5"},{"ecosystem":"RubyGems","fixed":["6.13.0"],"introduced":["6.0.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-gqvf-892r-vjm5"},{"ecosystem":"SUSE:Linux Enterprise Module for Advanced Systems Management 12","fixed":["3.8.5-15.12.1"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:rpm/suse/puppet\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Advanced%20Systems%20Management%2012","source":"SUSE-SU-2020:1057-1"}],"prev":{"headline":"Plone Unauthenticated Write Vulnerability","id":"CVE-2020-7941"},"products":["Puppet","Puppet Agent"],"published":"2020-02-19","related":[{"cvss_score":9.8,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","kev_date_added":null,"published":"2016-06-10"},{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.5,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","kev_date_added":null,"published":"2013-03-20"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Puppet"]},"summary":"Attackers with valid certificates can access other nodes' catalogs by modifying facts, exposing sensitive infrastructure data.","url":"https://insights.sbomify.com/CVE-2020-7942/"}