CVE-2020-7956 Improper Certificate Validation in HashiCorp Nomad

Critical 9.8 Published Updated

Attackers can escalate privileges by exploiting incorrect TLS certificate validation in HashiCorp Nomad's mTLS RPC mechanism.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-7956?

CVE-2020-7956 is a critical authentication bypass vulnerability in n/a, published on 31 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Weakness: CWE-295

Which versions are affected by CVE-2020-7956?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoAll versions0.10.3
github.com/hashicorp/nomad GoAll versions0.10.3
github.com/hashicorp/nomad GoAll versions0.10.3

Products include Hashicorp Nomad.

How do I fix CVE-2020-7956?

Upgrade github.com/hashicorp/nomad to 0.10.3 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2020-7956 being exploited?

There is no known exploitation of CVE-2020-7956 in the wild and no public exploit code.

Sources

Also known as GHSA-cj2h-ww36-v932, GO-2022-0821, UBUNTU-CVE-2020-7956.

Is CVE-2020-7956 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free