# CVE-2020-7964: Missing Authentication for Critical Function in Saleor

> Attackers can attach checkouts to arbitrary user IDs, leaking sensitive customer data like names and addresses in Saleor.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rgcm-rpq9-9cgr, PYSEC-2026-747

## What is CVE-2020-7964?

CVE-2020-7964 is a medium-severity missing authorization vulnerability in n/a, published on 24 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Mirumee Saleor 2.x before 2.9.1. Incorrect access control in the checkoutCustomerAttach mutations allows attackers to attach their checkouts to any user ID and consequently leak user data (e.g., name, address, and previous orders of any other customer).

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2020-7964?

3 open source packages ship an affected version, including saleor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `saleor` | PyPI | From 2.0.0 | 2.9.1 |
| `saleor` | PyPI | From 2.0.0 | 2.9.1 |
| `saleor` | PyPI | From 2.0.0 | 2.9.1 |

Products: Mirumee Saleor.

## How do I fix CVE-2020-7964?

Upgrade saleor to 2.9.1 or later.

## Is CVE-2020-7964 being exploited?

There is no known exploitation of CVE-2020-7964 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-13594](https://insights.sbomify.com/CVE-2019-13594/): Mirumee Saleor CSRF Protection Disabled (high 8.8)
- [CVE-2020-15085](https://insights.sbomify.com/CVE-2020-15085/): Client caching login operation with plaintext password in Saleor Storefront (medium 6.9)
- [CVE-2019-1010304](https://insights.sbomify.com/CVE-2019-1010304/): Missing authorization in Saleor (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-7964 and fix it if it is affected.

What it is: CVE-2020-7964 is a medium-severity missing authorization vulnerability in n/a, published on 24 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-7964 in the wild and no public exploit code.

Affected packages and fixed versions:
- saleor (PyPI): affected from 2.0.0; fixed in 2.9.1
- saleor (PyPI): affected from 2.0.0; fixed in 2.9.1
- saleor (PyPI): affected from 2.0.0; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-7964/ (Markdown: https://insights.sbomify.com/CVE-2020-7964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-7964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-7964
- OSV: https://osv.dev/vulnerability/CVE-2020-7964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-7964/
Summaries are generated and may contain mistakes; the official description above is the record.
