CVE-2020-7971 Cross-site scripting in n/a
Cross-site scripting vulnerability in GitLab EE allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-7971?
CVE-2020-7971 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
GitLab EE 11.0 and later through 12.7.2 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2020-7971?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.0.0 to 12.7.2 | 12.5.9, 12.6.6 |
Products include Gitlab Gitlab.
How do I fix CVE-2020-7971?
Upgrade gitlab to a fixed version for your release line: 12.5.9 or 12.6.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-7971 being exploited?
There is no known exploitation of CVE-2020-7971 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2020-7971, GHSA-g3q8-7g5m-j8cw.