{"answers":{"affected":"2 open source packages ship an affected version, including geocoder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-7981 in the wild and no public exploit code.","fix":"Upgrade geocoder to 1.6.1 or later.","what":"CVE-2020-7981 is a critical SQL injection vulnerability in n/a, published on 25 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-7981 and fix it if it is affected.\n\nWhat it is: CVE-2020-7981 is a critical SQL injection vulnerability in n/a, published on 25 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-7981 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- geocoder (RubyGems): affected all versions; fixed in 1.6.1\n- geocoder (RubyGems): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-7981/ (Markdown: https://insights.sbomify.com/CVE-2020-7981/index.md)","id":"CVE-2020-7981","markdown":"https://insights.sbomify.com/CVE-2020-7981/index.md","name":"CVE-2020-7981","record":{"aliases":["DEBIAN-CVE-2020-7981","GHSA-864j-6qpp-cmrr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby geocoding library","requires_auth":"none","summary":"Attackers can execute SQL injection via untrusted coordinates in the Geocoder Ruby library, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"geocoder","vendor":"rubygeocoder"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"sql.rb in Geocoder before 1.6.1 allows Boolean-based SQL injection when within_bounding_box is used in conjunction with untrusted sw_lat, sw_lng, ne_lat, or ne_lng data.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL Injection in Geocoder","id":"CVE-2020-7981","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"sql_injection","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Supply chain in n/a","id":"CVE-2020-7982"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"geocoder","purl":null,"source":"GHSA-864j-6qpp-cmrr"},{"ecosystem":"RubyGems","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"geocoder","purl":"pkg:gem/geocoder","source":"GHSA-864j-6qpp-cmrr"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2020-7980"},"products":["n/a"],"published":"2020-01-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute SQL injection via untrusted coordinates in the Geocoder Ruby library, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2020-7981/"}