# CVE-2020-8022: User-writeable configuration file /usr/lib/tmpfiles.d/tomcat.conf allows for escalation of priviliges

> Local attackers can escalate privileges from tomcat group to root due to incorrect default permissions on a configuration file.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2020
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-tomcat-2020-8022, SUSE-SU-2020:1788-1, SUSE-SU-2020:1789-1, SUSE-SU-2020:1790-1, SUSE-SU-2020:1791-1, openSUSE-SU-2020:0911-1

## What is CVE-2020-8022?

CVE-2020-8022 is a high-severity vulnerability in Apache Tomcat, published on 29 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Incorrect Default Permissions vulnerability in the packaging of tomcat on SUSE Enterprise Storage 5, SUSE Linux Enterprise Server 12-SP2-BCL, SUSE Linux Enterprise Server 12-SP2-LTSS, SUSE Linux Enterprise Server 12-SP3-BCL, SUSE Linux Enterprise Server 12-SP3-LTSS, SUSE Linux Enterprise Server 12-SP4, SUSE Linux Enterprise Server 12-SP5, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 12-SP2, SUSE Linux Enterprise Server for SAP 12-SP3, SUSE Linux Enterprise Server for SAP 15, SUSE OpenStack Cloud 7, SUSE OpenStack Cloud 8, SUSE OpenStack Cloud Crowbar 8 allows local attackers to escalate from group tomcat to root. This issue affects: SUSE Enterprise Storage 5 tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP2-BCL tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP2-LTSS tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP3-BCL tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP3-LTSS tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server 12-SP4 tomcat versions prior to 9.0.35-3.39.1. SUSE Linux Enterprise Server 12-SP5 tomcat versions prior to 9.0.35-3.39.1. SUSE Linux Enterprise Server 15-LTSS tomcat versions prior to 9.0.35-3.57.3. SUSE Linux Enterprise Server for SAP 12-SP2 tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server for SAP 12-SP3 tomcat versions prior to 8.0.53-29.32.1. SUSE Linux Enterprise Server for SAP 15 tomcat versions prior to 9.0.35-3.57.3. SUSE OpenStack Cloud 7 tomcat versions prior to 8.0.53-29.32.1. SUSE OpenStack Cloud 8 tomcat versions prior to 8.0.53-29.32.1. SUSE OpenStack Cloud Crowbar 8 tomcat versions prior to 8.0.53-29.32.1.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-8022?

1 open source package ship an affected version, including tomcat. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | All versions | 9.0.35-3.57.3 |
| `tomcat` | SUSE:Enterprise Storage 5 | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:HPE Helion OpenStack 8 | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 9.0.35-3.57.3 |
| `tomcat` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 9.0.35-3.57.3 |
| `tomcat` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP1 | All versions | 9.0.35-4.35.1 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP2-BCL | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP2-LTSS | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP3-BCL | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP3-LTSS | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 9.0.35-3.39.1 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 9.0.35-3.39.1 |
| `tomcat` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 9.0.35-3.57.3 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 12 SP2 | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 9.0.35-3.39.1 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 9.0.35-3.39.1 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 9.0.35-3.57.3 |
| `tomcat` | SUSE:OpenStack Cloud 7 | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:OpenStack Cloud 8 | All versions | 8.0.53-29.32.1 |
| `tomcat` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 8.0.53-29.32.1 |
| `tomcat` | openSUSE:Leap 15.1 | All versions | 9.0.35-lp151.3.21.1 |

Products: Apache Tomcat, Opensuse Leap.

## How do I fix CVE-2020-8022?

Upgrade tomcat to 9.0.35-3.57.3 or later.

## Is CVE-2020-8022 being exploited?

There is no known exploitation of CVE-2020-8022 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8022 and fix it if it is affected.

What it is: CVE-2020-8022 is a high-severity vulnerability in Apache Tomcat, published on 29 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8022 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected all versions; fixed in 9.0.35-3.57.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8022/ (Markdown: https://insights.sbomify.com/CVE-2020-8022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8022
- OSV: https://osv.dev/vulnerability/CVE-2020-8022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8022/
Summaries are generated and may contain mistakes; the official description above is the record.
