{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-8024 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-8024 is a medium-severity vulnerability in openSUSE Factory, published on 29 Jun 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-8024 and fix it if it is affected.\n\nWhat it is: CVE-2020-8024 is a medium-severity vulnerability in openSUSE Factory, published on 29 Jun 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-8024 in the wild and no public exploit code.\n\nAffected product: openSUSE Factory. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-8024/ (Markdown: https://insights.sbomify.com/CVE-2020-8024/index.md)","id":"CVE-2020-8024","markdown":"https://insights.sbomify.com/CVE-2020-8024/index.md","name":"CVE-2020-8024","record":{"aliases":["GHSA-rv88-x9wr-52g7","UBUNTU-CVE-2020-8024","openSUSE-SU-2020:0958-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"openSUSE hylafax+ package","requires_auth":"none","summary":"Local attackers can escalate privileges from the uucp user to other users due to incorrect default permissions in the hylafax+ package.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"hylafax\\+","vendor":"opensuse"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A Incorrect Default Permissions vulnerability in the packaging of hylafax+ of openSUSE Leap 15.2, openSUSE Leap 15.1, openSUSE Factory allows local attackers to escalate from user uucp to users calling hylafax binaries. This issue affects: openSUSE Leap 15.2 hylafax+ versions prior to 7.0.2-lp152.2.1. openSUSE Leap 15.1 hylafax+ version 5.6.1-lp151.3.7 and prior versions. openSUSE Factory hylafax+ versions prior to 7.0.2-2.1.","ecosystems":["openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Problematic permissions in hylafax+ packaging allow escalation from uucp to other users","id":"CVE-2020-8024","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2020"},"n_packages":1,"n_references":2,"next":{"headline":"outdated entries in permissions profiles for /var/lib/pcp/tmp/* may cause security issues","id":"CVE-2020-8025"},"packages":[{"ecosystem":"openSUSE:Leap 15.1","fixed":["7.0.2-lp151.4.3.1"],"introduced":["0"],"last_affected":[],"package":"hylafax+","purl":"pkg:rpm/opensuse/hylafax+\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:0958-1"}],"prev":{"headline":"Local privilege escalation from ldap to root when using OPENLDAP_CONFIG_BACKEND=ldap in openldap2","id":"CVE-2020-8023"},"products":["openSUSE Factory","openSUSE Leap 15.1","openSUSE Leap 15.2"],"published":"2020-06-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["openSUSE"]},"summary":"Local attackers can escalate privileges from the uucp user to other users due to incorrect default permissions in the hylafax+ package.","url":"https://insights.sbomify.com/CVE-2020-8024/"}