{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-8026 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2020-8026 is a high-severity vulnerability in Opensuse Backports Sle, published on 7 Aug 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-8026 and fix it if it is affected.\n\nWhat it is: CVE-2020-8026 is a high-severity vulnerability in Opensuse Backports Sle, published on 7 Aug 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-8026 in the wild and no public exploit code.\n\nAffected product: Opensuse Backports Sle. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-8026/ (Markdown: https://insights.sbomify.com/CVE-2020-8026/index.md)","id":"CVE-2020-8026","markdown":"https://insights.sbomify.com/CVE-2020-8026/index.md","name":"CVE-2020-8026","record":{"aliases":["GHSA-fm9w-35mc-phwx","openSUSE-SU-2020:1271-1","openSUSE-SU-2020:1272-1","openSUSE-SU-2020:1304-1","openSUSE-SU-2020:1427-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"openSUSE INN package","requires_auth":"none","summary":"Local attackers can escalate privileges to root due to incorrect default file permissions in the INN package on openSUSE.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"tumbleweed","vendor":"opensuse"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A Incorrect Default Permissions vulnerability in the packaging of inn in openSUSE Leap 15.2, openSUSE Tumbleweed, openSUSE Leap 15.1 allows local attackers with control of the new user to escalate their privileges to root. This issue affects: openSUSE Leap 15.2 inn version 2.6.2-lp152.1.26 and prior versions. openSUSE Tumbleweed inn version 2.6.2-4.2 and prior versions. openSUSE Leap 15.1 inn version 2.5.4-lp151.3.3.1 and prior versions.","ecosystems":["SUSE:Package Hub 15 SP1","SUSE:Package Hub 15 SP2","openSUSE:Leap 15.1","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"inn: non-root owned files","id":"CVE-2020-8026","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:backports_sle","products":["opensuse:backports_sle","opensuse:leap"],"type":"privilege_escalation","year":"2020"},"n_packages":4,"n_references":5,"next":{"headline":"openldap uses fixed paths in /tmp","id":"CVE-2020-8027"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["2.5.4-bp151.4.6.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/suse/inn\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2020:1304-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.6.2-bp152.2.4.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/suse/inn\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2020:1427-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["2.5.4-lp151.3.6.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/opensuse/inn\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:1271-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["2.6.2-lp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/opensuse/inn\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2020:1272-1"}],"prev":{"headline":"outdated entries in permissions profiles for /var/lib/pcp/tmp/* may cause security issues","id":"CVE-2020-8025"},"products":["openSUSE Leap 15.1","openSUSE Leap 15.2","openSUSE Tumbleweed"],"published":"2020-08-07","related":[{"cvss_score":9.8,"headline":"Roundcube Webmail Remote Code Execution","id":"CVE-2020-12641","kev_date_added":"2023-06-22","published":"2020-05-04"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2020-12640","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":8.8,"headline":"Command injection in EdgeSwitch firmware v1.9.0 and prior","id":"CVE-2020-8233","kev_date_added":null,"published":"2020-08-17"},{"cvss_score":8.2,"headline":"Path traversal and files overwrite with unsquashfs","id":"CVE-2020-15229","kev_date_added":null,"published":"2020-10-14"},{"cvss_score":7.8,"headline":"Command injection in Shadowsocks","id":"CVE-2019-5164","kev_date_added":null,"published":"2019-12-03"},{"cvss_score":7.8,"headline":"Path traversal in n/a","id":"CVE-2019-9896","kev_date_added":null,"published":"2019-03-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["openSUSE"]},"summary":"Local attackers can escalate privileges to root due to incorrect default file permissions in the INN package on openSUSE.","url":"https://insights.sbomify.com/CVE-2020-8026/"}