{"answers":{"affected":"2 open source packages ship an affected version, including reveal.js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-8127 in the wild and no public exploit code.","fix":"Upgrade reveal.js to 3.9.2 or later.","what":"CVE-2020-8127 is a medium-severity cross-site scripting vulnerability in reveal.js, published on 28 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-8127 and fix it if it is affected.\n\nWhat it is: CVE-2020-8127 is a medium-severity cross-site scripting vulnerability in reveal.js, published on 28 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-8127 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- reveal.js (npm): affected all versions; fixed in 3.9.2\n- reveal.js (npm): affected all versions; fixed in 3.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-8127/ (Markdown: https://insights.sbomify.com/CVE-2020-8127/index.md)","id":"CVE-2020-8127","markdown":"https://insights.sbomify.com/CVE-2020-8127/index.md","name":"CVE-2020-8127","record":{"aliases":["GHSA-6vwx-mwp8-fh44"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"reveal.js presentation library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in the context of users viewing presentations due to insufficient validation in postMessage handling.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"reveal.js","vendor":"revealjs"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in reveal.js","id":"CVE-2020-8127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Server-Side Request Forgery and Inclusion of Functionality from Untrusted Control Sphere in jsreport","id":"CVE-2020-8128"},"packages":[{"ecosystem":"npm","fixed":["3.9.2"],"introduced":["0"],"last_affected":[],"package":"reveal.js","purl":null,"source":"GHSA-6vwx-mwp8-fh44"},{"ecosystem":"npm","fixed":["3.9.2"],"introduced":["0"],"last_affected":[],"package":"reveal.js","purl":"pkg:npm/reveal.js","source":"GHSA-6vwx-mwp8-fh44"}],"prev":{"headline":"Command injection in EdgeSwitch","id":"CVE-2020-8126"},"products":["reveal.js"],"published":"2020-02-28","related":[{"cvss_score":5.3,"headline":"Cross-site Scripting (XSS) - DOM in hakimel/reveal.js","id":"CVE-2022-0776","kev_date_added":null,"published":"2022-03-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in the context of users viewing presentations due to insufficient validation in postMessage handling.","url":"https://insights.sbomify.com/CVE-2020-8127/"}