# CVE-2020-8127: Cross-site Scripting in reveal.js

> Attackers can execute arbitrary scripts in the context of users viewing presentations due to insufficient validation in postMessage handling.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6vwx-mwp8-fh44

## What is CVE-2020-8127?

CVE-2020-8127 is a medium-severity cross-site scripting vulnerability in reveal.js, published on 28 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-8127?

2 open source packages ship an affected version, including reveal.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reveal.js` | npm | All versions | 3.9.2 |
| `reveal.js` | npm | All versions | 3.9.2 |

Products: Revealjs Reveal.js.

## How do I fix CVE-2020-8127?

Upgrade reveal.js to 3.9.2 or later.

## Is CVE-2020-8127 being exploited?

There is no known exploitation of CVE-2020-8127 in the wild and no public exploit code.

## Other vulnerabilities in reveal.js

- [CVE-2022-0776](https://insights.sbomify.com/CVE-2022-0776/): Cross-site Scripting (XSS) - DOM in hakimel/reveal.js (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8127 and fix it if it is affected.

What it is: CVE-2020-8127 is a medium-severity cross-site scripting vulnerability in reveal.js, published on 28 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-8127 in the wild and no public exploit code.

Affected packages and fixed versions:
- reveal.js (npm): affected all versions; fixed in 3.9.2
- reveal.js (npm): affected all versions; fixed in 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8127/ (Markdown: https://insights.sbomify.com/CVE-2020-8127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8127
- OSV: https://osv.dev/vulnerability/CVE-2020-8127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8127/
Summaries are generated and may contain mistakes; the official description above is the record.
