{"answers":{"affected":"2 open source packages ship an affected version, including script-manager. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-8129 in the wild and no public exploit code.","fix":"Upgrade script-manager to 0.9.0 or later.","what":"CVE-2020-8129 is a critical code injection vulnerability in script-manager, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-8129 and fix it if it is affected.\n\nWhat it is: CVE-2020-8129 is a critical code injection vulnerability in script-manager, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-8129 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- script-manager (npm): affected all versions; fixed in 0.9.0\n- script-manager (npm): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-8129/ (Markdown: https://insights.sbomify.com/CVE-2020-8129/index.md)","id":"CVE-2020-8129","markdown":"https://insights.sbomify.com/CVE-2020-8129/index.md","name":"CVE-2020-8129","record":{"aliases":["GHSA-rhwf-hqpr-q8g2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm script-manager package","requires_auth":"none","summary":"Attackers can execute arbitrary code via an unintended require vulnerability in the script-manager npm package.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"script-manager","vendor":"script-manager_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An unintended require vulnerability in script-manager npm package version 0.8.6 and earlier may allow attackers to execute arbitrary code.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code Injection in script-manager","id":"CVE-2020-8129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"OS Command Injection in Rake","id":"CVE-2020-8130"},"packages":[{"ecosystem":"npm","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"script-manager","purl":null,"source":"GHSA-rhwf-hqpr-q8g2"},{"ecosystem":"npm","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"script-manager","purl":"pkg:npm/script-manager","source":"GHSA-rhwf-hqpr-q8g2"}],"prev":{"headline":"Server-Side Request Forgery and Inclusion of Functionality from Untrusted Control Sphere in jsreport","id":"CVE-2020-8128"},"products":["script-manager"],"published":"2020-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via an unintended require vulnerability in the script-manager npm package.","url":"https://insights.sbomify.com/CVE-2020-8129/"}