# CVE-2020-8129: Code Injection in script-manager

> Attackers can execute arbitrary code via an unintended require vulnerability in the script-manager npm package.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rhwf-hqpr-q8g2

## What is CVE-2020-8129?

CVE-2020-8129 is a critical code injection vulnerability in script-manager, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An unintended require vulnerability in script-manager npm package version 0.8.6 and earlier may allow attackers to execute arbitrary code.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-8129?

2 open source packages ship an affected version, including script-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `script-manager` | npm | All versions | 0.9.0 |
| `script-manager` | npm | All versions | 0.9.0 |

Products: Script-Manager Project Script-Manager.

## How do I fix CVE-2020-8129?

Upgrade script-manager to 0.9.0 or later.

## Is CVE-2020-8129 being exploited?

There is no known exploitation of CVE-2020-8129 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8129 and fix it if it is affected.

What it is: CVE-2020-8129 is a critical code injection vulnerability in script-manager, published on 14 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8129 in the wild and no public exploit code.

Affected packages and fixed versions:
- script-manager (npm): affected all versions; fixed in 0.9.0
- script-manager (npm): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8129/ (Markdown: https://insights.sbomify.com/CVE-2020-8129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8129
- OSV: https://osv.dev/vulnerability/CVE-2020-8129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8129/
Summaries are generated and may contain mistakes; the official description above is the record.
